map broken / osmdroid banned from osm/mapnik!?

Suggestions for WiGLE/JiGLE/DiGLE

17 posts • Page 1 of 2
today i noticed new map tiles weren't loading in the wigle wifi app.
so i did some research, and tried to reset caches, moving folders and such.
but the problem is a much more profound one: osmdroid seems to be banned from osm/mapnik! :(
http://stackoverflow.com/questions/2119 ... er-working
so my question is:
would it be possible to introduce a setting, where we can choose a map provider?
-hdmn
Oh nooe! We're working on a fix.
-bobzilla - WiGLE.net just a little bit
Image
version 1.58 of wigle wifi wardriving for android now has a setting to use wigle for the OSM tiles.
thank you! what an excellent response time! :)
are you mirroring selected zoom levels only or is just really busy right now!?
-hdmn
they're cached + rendered locally to wigle, so depending on how tired the kittens are, it can take longer than expected the first time through an area.
perfect. now it's running pretty well. thank you!
-hdmn
The map still isn't working for me on the android app.
Is it US only?
if you can see it on the webmaps with "Use OpenStreetMap" checked, it should work in the android app.
it does take a bit the first time through an area for the OSM tiles to get rendered/cached.
I can see the map on the webmaps with the "Use OpenStreetMap" option

But even there, the map is really incomplete. Looks like a very old version of it, while on OpenStreetMap site I get the full complete map.

Compare the maps of the same place.
https://wigle.net/gps/gps/Map/onlinemap ... Types=CDMA
http://www.openstreetmap.org/search?que ... 2/-47.8050

Edit: It took a while but the map appeared on the Android App. The old incomplete map, the same as the webmaps.
Aye, it's an older snapshot of osm data, if we keep this architecture we'll have to spin up the rolling updates. We had to do a quick fix when the library was denied.
-bobzilla - WiGLE.net just a little bit
Image
The osm renderd also likes to segfault, have had to add a wrapper to spin it back up when that happens :)
-bobzilla - WiGLE.net just a little bit
Image
And if the server check for tiles updates when someone access them?

Or maybe weekly update?

Those tiles right now are very old…
Aye, the dataset we have was loaded a while ago, updating it is on the long todo list.
-bobzilla - WiGLE.net just a little bit
Image
Is there a way to manually D/L map tiles within the Android apk? Just installed today, and while discovered points seem to be plotted relative to my position, I've no map images. Any suggestions?
if you're the first to pull up an area it can take a bit for the tiles to generate.
check the webmaps for that area with the "open street maps" checkbox checked.
if they still don't show up send us a link/note.

17 posts • Page 1 of 2

Return to “WiGLE Project Suggestions”

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 7 guests