Page 1 of 1

Waiting for GPS sync (tested on 2 different devices)

Posted: Thu Jul 30, 2020 1:14 pm
by dastan
I installed the Android app on two devices and on both it is stuck on "Waiting for GPS sync". I checked all the settings and permissions and it should work. The map recognizes my location, but the app doesn't. On my dashboard there is a red cross after "Loc".

I tried reinstalling the app and I restarted the phones several times.

Any idea what's causing this?

Thanks in advance. The app looks great and I'd love to get it working.

Re: Waiting for GPS sync (tested on 2 different devices)

Posted: Thu Jul 30, 2020 11:25 pm
by arkasha
sorry to hear that; we've had a few isolated reports like this, but never anything reproducible on a more than individual scale.

Some things that would help:
1. Android version(s)
2. location settings - how did you verify app access
3. Testing location/local
4. carrier
5. devices
6. your location

Obviously if you're not comfortable sharing those on a public forum, we're happy to switch to email (WiGLE-admin[at]wigle.net) or PM.
If you happen to be an Android developer the best possible case would be watching the process logs as you launch the app - if there's an error, it would manifest there. If it's just a really bad GPS sync, there won't be much useful. So far, in one case, we discovered that post schism, Huawei has started *changing* Android in ways that don't comply with the spec. In others, devices were operating on purely network location but the app wasn't allowed to receive network location data.

Re: Waiting for GPS sync (tested on 2 different devices)

Posted: Fri Jul 31, 2020 6:53 am
by dastan
Thank you for your quick response.

Apparently the GPS signal is very weak inside my house, because outside the app was working well.

:D