WiGLE location no longer runs in 'background'

Issues with the Android network detection software. Please include Software version, Android version, and device when reporting

46 posts • Page 2 of 4
Pausing the scan stops the WiFi scanner; cycling the WiFi radio is a more power-intensive operation than running the GPS. If you're not moving, Pausing the scan is a fine idea.

There isn't currently a way to clear the run or new count, since those numbers indicate "since the app was started this time."
Great, I will go for pausing for the time being, doing some other tests to see why it is only when Tasker launches WiGLE that it is not able to run in the background properly.
Image
I was using a Lenovo P2 with android 7 and Samsung Galaxy tab A with android 10 no problems, but then the Tab A auto-updated to android 11 then the wifi kept on jamming, I had already disabled the throttling in the developer options and unistalled/reinstalled various times but no way to overcome the jammed wifi when the screen went to sleep. It was clear it was a wifi issue as the Bluetooth was still counting up, so GPS was still running as was the actual wigle app itself. I recenty got a Samsung A71 on android 11 and it had the same issues as the tablet.

Eventually worked out the I had to disable a location setting and both devices are back to working normal again.

Settings > Location > Improve accuracy > WIFI scanning (OFF)

seems like for some reason Samsung has implemented a background process where the location service takes over the wifi signals to try and improve the GPS fix of the phone
that's a weird outcome!

random experiment to try: "pausing" scanning in the app doesn't turn off the scan receiver, it's stops the process that initiates scans on our behalf. This means that if you pause scanning, but another process on the device is initiating scans, you get the results of those updates. If you pause scanning in WiGLE and enable "WiFi Scanning," does the app keep getting updates? If yes, does it update faster or slower than your WiGLE scan settings? (If no, it probably means that the Samsung driver scans are taking place outside of Android).

Jammed WiFi usually indicates contention, or trying to scan faster than the driver/chipset can handle; it would be interesting to see what settings wouldn't "fight" with the OS scanning.
Just started having this issue as well -

Pixel 3a - Android 11 - build RQ3A.210905.001
Using latest WiGLE version

When screen sleeps GPS seems to turn off and WiGLE stops scanning.
Upon re-awakening phone GPS restarts and scanning starts again.

I've restarted my phone a couple of times and no luck. I really can't afford to leave the screen on all the time!

Suggestions?
that definitely doesn't happen on other Pixel 3a devices. A few questions:
- are you running a custom OS build?
- Do you have unusual power saving measures engaged?
- have you allowed permission for fine-and-coarse grained location?
- are you running a custom OS build?
- Do you have unusual power saving measures engaged?
- have you allowed permission for fine-and-coarse grained location?
Stock Android build just uploaded a few days ago RQ3A.210905.001
No special power saving
Don't know what fine and coarse grain location setting is

It has been working for ages - check my uploads. Suddenly stopped working except when I keep the screen active.
Well that's not good news.

1. check the permissions under Settings -> Applications -> WiGLE Wifi Wardriving" -> permissions: make sure it has the stuff it asks for (sometimes Android "optimizes" these for you starting in 11, and withdraws them on your behalf)
2. Did you get an OS upgrade recently? Have you done the activate-developer-mode -> deactivate "WiFi Scan Throttling?"

Cheers,

-ark and the WiGLE team
1. check the permissions under Settings -> Applications -> WiGLE Wifi Wardriving" -> permissions: make sure it has the stuff it asks for (sometimes Android "optimizes" these for you starting in 11, and withdraws them on your behalf)
2. Did you get an OS upgrade recently? Have you done the activate-developer-mode -> deactivate "WiFi Scan Throttling?"
WiGLE didn't have access to phone or camera - I turned the on.

I did get a security update - I had previously done the developer mode thing. I just checked again and the WiFi throttling was already off.

Still not scanning correctly. Sitting here at home I open the app, it gets GPS location and starts scanning. I set the phone aside and look again a couple of minutes later. No access points showing, GPS reconnects, scanning resumes and access points reappear.
hm, the camera's just for the QR-scan for account login, and "phone" is just to deactivate TTS when you're on the phone.
I'm linking this thread to a twitter post in hopes of getting some independent confirmation from other folks with 3as. It's a major problem if it's widespread. If not, we can get some folks to help track down differences / isolate the issue.
I confirmed my Pixel 3a on RQ3A.210805.001 would continue to scan while locked. Seeing this thread I've updated to RQ3A.210905.001 and based on a quick stroll around the office it looks like my Pixel is still able to scan while locked (based on BT device counts incrementing).
thanks for helping out!

Still trying to think of what would shut the GPS off when the screen is off. It's a conditional setting Apple provides now, but not common in Android (it would require either a developer setting, or an app that made it happen intentionally, certainly something we don't do!). Google phones run a nice "standard" edition of Android, so it's not weird vendor stuff.
I had a go at this tonight since I have the same phone. I went for a walk with a Pixel 2, Pixel 3a and Pixel 4a 5g. All with the latest updates and developer setting so that WIFI scanning is not limited. Surprisingly, the Pixel 3a worked fine, but the Pixel 2 stopped scanning WIFI, but the GPS kept working and BT scanning continued for the whole walk. I'll keep an eye out to see if I can find a way to reproduce this.
Just updated my OnePlus 6 running LineageOS 18.1 and am having this issue. Seems that this behavior is related to the September Android security update.
I confirmed my Pixel 3a on RQ3A.210805.001 would continue to scan while locked. Seeing this thread I've updated to RQ3A.210905.001 and based on a quick stroll around the office it looks like my Pixel is still able to scan while locked (based on BT device counts incrementing).
It looks like my Pixel 3a on RQ3A.210905.001 *is* having problems scanning when the phone is locked. I started a scan on the way into work this AM and locked the phone. On arrival 20 minutes later when I unlocked the phone, my wifi and BT counts were under 10 each which is very atypical.

46 posts • Page 2 of 4

Return to “WiGLE WiFi Wardriving Bugs”

Who is online

Users browsing this forum: No registered users and 3 guests