Welcome new users, a note about the interactive maps

The frontpage news bits

11 posts • Page 1 of 1
So, it's been a pretty crazy ten hours, as people have discovered WiGLE for the first time, thanks to an exciting news story. We appreciate the interest, and are doing our best to scale with demand.

Our mapping core has needed some significant work for a while, and this has been just the kick in the butt we needed... however, we're fixing things incrementally to keep things working as best we can. The status for now:

We've found and fixed several bugs this evening (thank you for the feedback), and most of the site is working and keeping up.
Searching via the search page will continue to work during this time.
The web maps will be vending data from 2015 to the present day as a short-term solution, while we improve our back-end tile generation over the coming week.
Hey Ark, the maps at the moment are looking woefully underpopulated with dots on my side of town. Definitely not representing all the points that have been collected in the Twin Cities, MN since 2015. New tile generator gone a bit wonky perhaps?
Sure enough, we're still light on the data front. The team is on it!

PS> search pages are still operating on all data; only the map tile generation system failed to keep pace.
I think the link you posted for the news story was copied incorrectly.

Edit: It wasn't.
Last edited by WestonReed on Wed Feb 22, 2017 1:09 am, edited 1 time in total.
If it's about the Nintendo Switch, that's the one! People flocked to WIGLE to discover the approximate location of the creator of the demo video, based on the networks visible on the Switch setup screen.
Well, from the point of view of a novice, Maps definitely is not working

1) Filters don't work in interactive maps at all, use any filter and all that happens is that all data disappears, not just the data you are trying to filter out
2) Virtually impossible to see any data, just tiny red dots mark any locations with no information attached to them at most magnifications
3) even when zooming in, all that is displayed instead of tiny red dot is a label with network name, but not possible to hover over or to click on label to drill down on data to see anything further about that network. Cursor just remains same "hand" as is used to move the underlying google map. This is true regardless of how long one waits for map/data to finish loading

Maybe on 2 and 3 it was designed that way, though that seems unlikely as it would defeat whole point of collecting the data
[quote="arkasha"]Sure enough, we're still light on the data front. The team is on it!

PS> search pages are still operating on all data; only the map tile generation system failed to keep pace.[/quote]

I was thinking that you'd simply purged all the old AP data which, given what I see locally, wouldn't be a bad thing - it looks like most users replace their access points every few years.
Interactive maps now once again contain all data. Over the coming weeks, we'll work on ways to make mapserver startup more efficient, and make the maps more powerful.
Another novice here, but I didn't find WIGLE because of that thread, but rather due to a discussion on an IRC channel.
Filtering on interactive maps doesn't completely work. Specifically, the options "Wifi Net" "CDMA cellular net" "GSM cellular net" do absolutely nothing.
Another thing, using the detailed search isn't perfect either. Entering a search in London for [code]%london%[/code] shows an error message, "SSIDlike fails validation; must be between 1 and 32 octets" and no results are displayed. (this happens with any %largecity% search within that city, as far as I tested).
Hi there, thanks for your interest

Per the instructions on the detailed search (SSID cannot start with a wildcard. '%' means zero-or-more characters, '_' means a single character.), leading wildcards aren't supported for SSID searches. It's also important to note that city name and SSID are not related - not sure if that's what you're trying to illustrate with the example, but you'll need to establish some coordinate boundaries first (optionally using Geocoding by city name) before searching. SSID/SSIDlike are the name of the network.

It's probably a good idea to combine those fields in the search interface, and improve the UI for boundaries vs. search criteria.

I'll look into the filter options for the maps next.

Thanks for the heads-up - you're right, our network-type filters have been broken on the web maps for a long time. It's taken some investigation, but those should be fixed now.

Thanks for your input and interest!

11 posts • Page 1 of 1

Return to “WiGLE Frontpage”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest