WiGLE WiFi Wardriving app unable to export .gpx files from saved routes

Issues with the Android network detection software. Please include Software version, Android version, and device when reporting

6 posts • Page 1 of 1
I accidentally refreshed the page & lost the entire thing I wrote. I may miss some things retyping this.

I'm trying to export my saved routes as.gpx files so I can use them in OpenStreetMap. When I try to export a .gpx file from saved routes in the WiGLE app by clicking the share button, I'm shown a list of my apps. I see messengers, cloud storage, nearby share, & file managers. No matter what I select the export fails; messengers fail to send, cloud storage fails to upload, & file managers fail to copy the file. When I go back to the WiGLE app to try again no list of apps ever appears, & all that happens is a loading bar saying "Working…" appears at the bottom of the screen. No matter how long I wait nothing happens. In order to make the app list appear again the app must be force stopped, just closing the activity & relaunching the app does not make it appear again. Is this a known issue? Is there some other way I can get GPS traces out of WiGLE? I have all permissions enabled for both WiGLE & for the apps I'm trying to use to receive the exported file. I have been able to export .gpx files this way in past versions of the WiGLE app.

This also affects the "Export current route as a GPX route file" function directly above "saved routes" in the database tab.

Google Pixel 6 Pro running Android 13 (TQ3A.230901.001)
WiGLE WiFi Wardriving version 2.84 installed from Google Play

I can provide video of reproducing the issue if needed. I can also provide a debug log generated inside the app from while I was doing this. I would use the "Send error report" feature in the settings section but I'm not sure how to generate one.
Interesting -

A couple of questions:
- are you using the FOSS branch or a custom build?
- Does a transient "toast" error message appear if you keep watching the screen?
- How long a route are you trying to export (number of points shown after the route entry in the list) / how long does it take?
- Is it possible you have a problem with your network connection?

I'll note that exiting the application (without "force stop") should always clear any problem like this, but you do have to use the "Exit" menu item. If this doesn't end the process of trying to send the file, that means something is happening with Android outside the app and it can't complete the transfer.
I'm using the Google Play build
https://play.google.com/store/apps/deta ... gleandroid

No toast messages in saved routes, but sometimes one appears with "Export current route as a GPX route file," only after attempting to export from saved routes. It says "Unable to export GPX file. A job of this type is already running or waiting to run.", can't remember exact phrasing. No toast message when starting fresh after killing the app. Toast never appears in saved routes either.

Route length varies, I've tried just about 200ft. & about 40 miles. Two minutes or two hours. Same result.

No network issues at all, I tried on a stable Wi-Fi connection, 4G, & 5G.

Exiting the app does seem to properly shut down WiGLE, & when launching it again the loading bar is gone, it does not seem to be transferring anymore, however the app menu when trying to export does not appear again until it's force stopped. When exporting with a file manager, doesn't matter which one, it says the file is zero bytes & is unable to transfer anything at all. I know that the data exists though because I can see the path in WiGLE. I also have not updated Android since the last time I did this & it worked last time, but I have updated WiGLE since last time & now it's not working. I also want to note that all of the .kml & .csv functions work completely fine, I just have no way to use those for OpenStreetMap so I can't try to substitute with those. Trying to export .kml or .csv after failing to export .gpx also works & causes the loading bar to disappear.
I think we've got a line on this one - it's fixed in github, but not in a released yet - watch for 2.85 for a fix!

Thanks for the heads-up
Thank you so much! I appreciate the help!
Fix now in 2.85 - released in the Play Store Beta channel

6 posts • Page 1 of 1

Return to “WiGLE WiFi Wardriving Bugs”

Who is online

Users browsing this forum: No registered users and 32 guests