no scan when screen is off

Issues with the Android network detection software. Please include Software version, Android version, and device when reporting

4 posts • Page 1 of 1

Postby peterb » Thu Sep 13, 2018 3:51 pm

no new wifi network detected when app is in background or screen is off.
a few month ago it was working ok but since then it never detects new wifi networks.

android 6
v2.31

Postby bobzilla » Thu Sep 13, 2018 7:24 pm

That's odd, what device manufacturer? What carrier (which may have tweaked the OS)? I would guess the OS is deciding to kill the app or suppress wifi scans even though there's a foreground service (probably in some crusade for battery life). Could watch log output when connected to Android Studio via USB if that's something you can do, it might provide some insight.
-bobzilla - WiGLE.net just a little bit
Image

Postby peterb » Thu Sep 13, 2018 10:29 pm

this is a chinese manuf. letv x500 and there was no os upgrade in the last half or one year.

currently my pc is not working so i can't check any adb debug log.

no sim in the phone.

apps i am running when wigle runs are
runkeeper
mi fit - similar sports tracking
music with bluetooth

but these same apps were running when wigle in the bg worked.

Postby arkasha » Mon Sep 17, 2018 12:55 am

we're on the case - Google's been doing some annoying stuff with foreground/background, as have some vendors.

What OS version are you on? Depending, there might be some application "advanced" settings that get toggled (even without an upgrade) if WiGLE ends up being a heavy battery user (this can happen just because you run WiGLE a lot, like I do!) - see whether or not you can disable "background execution limits" for your OS version, you might get the anticipated performance back.

Sorry for the inconvenience.

-ark

4 posts • Page 1 of 1

Return to “WiGLE WiFi Wardriving Bugs”

Who is online

Users browsing this forum: No registered users and 0 guests