lastupdt : invalid date format

Found a problem? Tell us about it! Topics-per-issue, please search before posting.

5 posts • Page 1 of 1

Postby stout990 » Tue Nov 30, 2021 5:17 pm

Hi All,

Great project! I'm trying to use the API to query Bluetooth search results; I've had no problems thus far until I reached 'lastupdt'. The Swagger docs show that the date format should be yyyyMMdd[hhmm[ss]]. When I do so, I receive:

Code: Select all

{"success":false,"message":"invalid lastupdt format."}
I've also tried encoding the value (as the Swagger test harness does so) and I see the same result.

An example date I am using is as follows: 20210601[1200[00]]

Any suggestions would be appreciated. Thanks.

Postby arkasha » Wed Dec 01, 2021 5:43 pm

ah, sorry - probably a bad mix of documentation conventions - the square brackets indicate optional elements, not required formatting.
so value values are:

Code: Select all


Code: Select all


Code: Select all


Postby stout990 » Mon Dec 06, 2021 4:29 pm

Thank you for the reply! Query is working now; appreciate it.

Postby stout990 » Mon Dec 06, 2021 7:15 pm

However, I've yet to actually return any results when applying a 'lastupdt' parameter, even going so far back as 2010. I was hoping to return back more recent results than going back to 2001 and I figured 'lastupdt' was that parameter. Should I instead use 'endTransId'?

Postby arkasha » Mon Dec 06, 2021 8:09 pm

Depending on your other query parameters and intended use, it varies!
You can see which networks were seen more and less recently using the sliders on the webmaps.

using startTransID and endTransIDs are a very reliable way of bounding on upload time if you want to date-limit your query - give those a try, and feel free to reach out in DM if you're not comfortable sharing your query publicly!


5 posts • Page 1 of 1

Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 2 guests