WiGLE WiFi Wardriving 2.31 crashing on launch

Issues with the Android network detection software. Please include Software version, Android version, and device when reporting

7 posts • Page 1 of 1
Ever since the 2.31 update, WiGLE WiFi Wardriving crashes on my Galaxy S4 running Android 4.4.4. As soon as I try to launch the app, it immediately crashes and prompts for submitting a report with system logs. I've done that a few times, but I'm not entirely sure where those emails even go.

Aside from factory resetting my phone, do I have any options here? The last 4 or 5 previous builds worked great. I have uninstalled and re-installed a few times, with no improvement. Is there any other information I could provide to help troubleshoot this?

Hi DaClyde,

you're absolutely right - we unintentionally introduced a problem in our new cell stumbling implementation. because older Samsungs have a known problem with SQLite DB access in certain threading circumstances, sometimes looking up the network IDs freaks out. if you're feeling brave, the beta channel version should fix this; if not, we're gonna fix one more issue in the beta, then cut a new release, which should repair everything.

Thanks for the feedback, sorry for the PITA; we didn't know about this weird quirk.


-Ark and the WiGLE team
No luck with the 2.3.5 built, just a different kind of crash.
new version rolling out on partial right now - any luck with 2.36?
2.36 stays open, without crashing! I'll take it for a spin this afternoon. Thanks!
2.36 seems to have fixed it. Everything seems to be running properly, now. Thanks for working on that.
Glad to help, and thank you for your feedback!

There are so many different android devices out there, with different quirks and configurations, more than we can test ourselves. User reports keep up from going crazy.


-Ark and the WiGLE team

7 posts • Page 1 of 1

Return to “WiGLE WiFi Wardriving Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest